const regex = new RegExp('://[^.:]+', 'g')
const str = `http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test`;
const subst = `://{HOST_NAME}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);