$re = '~://[^.:]+~';
$str = 'http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test';
$subst = "://{HOST_NAME}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;