using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"://[^.:]+";
string substitution = @"://{HOST_NAME}";
string input = @"http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}