# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"://[^.:]+"
test_str = ("http://localhost:8080/test\n"
" -> http://{HOST_NAME}:8080/test\n"
"https://test-app.uk.ru/test\n"
" -> https://{HOST_NAME}.uk.ru/test")
subst = "://{HOST_NAME}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.