#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "://[^.:]+"
Local $sString = "http://localhost:8080/test" & @CRLF & _
" -> http://{HOST_NAME}:8080/test" & @CRLF & _
"https://test-app.uk.ru/test" & @CRLF & _
" -> https://{HOST_NAME}.uk.ru/test"
Local $sSubst = "://{HOST_NAME}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)