package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`://[^.:]+`)
var str = `http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test`
var substitution = "://{HOST_NAME}"
fmt.Println(re.ReplaceAllString(str, substitution))
}