// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"://[^.:]+").unwrap();
let string = "http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test";
let substitution = "://{HOST_NAME}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}