#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^XY]*)(Y)([^X]*)$|(.*)(X)"
Local $sString = "abcde" & @CRLF & _
"abcXe" & @CRLF & _
"abcdY" & @CRLF & _
"abcXY" & @CRLF & _
"abYcXY" & @CRLF & _
"abcYX"
Local $sSubst = "\1\41\3\5\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)