import re
regex = re.compile(r"^([^XY]*)(Y)([^X]*)$|(.*)(X)", flags=re.MULTILINE)
test_str = ("abcde\n"
"abcXe\n"
"abcdY\n"
"abcXY\n"
"abYcXY\n"
"abcYX")
subst = "\\1\\41\\3\\5\\2"
result = regex.sub(subst, test_str)
if result:
print(result)