re = /^([^XY]*)(Y)([^X]*)$|(.*)(X)/m
str = 'abcde
abcXe
abcdY
abcXY
abYcXY
abcYX'
subst = '\\1\\41\\3\\5\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result