// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^XY]*)(Y)([^X]*)$|(.*)(X)").unwrap();
let string = "abcde
abcXe
abcdY
abcXY
abYcXY
abcYX";
let substitution = "\\1\\41\\3\\5\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}