const regex = /^([^XY]*)(Y)([^X]*)$|(.*)(X)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^XY]*)(Y)([^X]*)$|(.*)(X)', 'gm')
const str = `abcde
abcXe
abcdY
abcXY
abYcXY
abcYX`;
const subst = `\1\41\3\5\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);