use strict;
my $str = 'abcde
abcXe
abcdY
abcXY
abYcXY
abcYX';
my $regex = qr/^([^XY]*)(Y)([^X]*)$|(.*)(X)/mp;
my $subst = '\\1\\41\\3\\5\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";