using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^XY]*)(Y)([^X]*)$|(.*)(X)";
string substitution = @"\1\41\3\5\2";
string input = @"abcde
abcXe
abcdY
abcXY
abYcXY
abcYX";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}