import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^XY]*)(Y)([^X]*)$|(.*)(X)";
final String string = "abcde\n"
+ "abcXe\n"
+ "abcdY\n"
+ "abcXY\n"
+ "abYcXY\n"
+ "abcYX";
final String subst = "\\1\\41\\3\\5\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}