$re = '/^([^XY]*)(Y)([^X]*)$|(.*)(X)/m';
$str = 'abcde
abcXe
abcdY
abcXY
abYcXY
abcYX';
$subst = "\1\41\3\5\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;