# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)/\1/gm;t' <<< "{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text"