re = /^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)/m
str = '{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result