const regex = new RegExp('^\\{(?:GROUP OF SPEAKERS|SPEAKER)\\}\\t(.*)', 'gm')
const str = `{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);