use strict;
my $str = '{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text';
my $regex = qr/^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";