import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{(?:GROUP OF SPEAKERS|SPEAKER)\\}\\t(.*)";
final String string = "{SPEAKER} Some text\n"
+ "{GROUP OF SPEAKERS} Some text";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}