using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)";
string substitution = @"\1";
string input = @"{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}