$re = '/^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)/m';
$str = '{SPEAKER} Some text
{GROUP OF SPEAKERS} Some text';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;