import re
regex = re.compile(r"^\{(?:GROUP OF SPEAKERS|SPEAKER)\}\t(.*)", flags=re.MULTILINE)
test_str = ("{SPEAKER} Some text\n"
"{GROUP OF SPEAKERS} Some text")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)