package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]`)
var str = `[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]`
var substitution = "[MEDIA=sketchfab]$1[/MEDIA]"
fmt.Println(re.ReplaceAllString(str, substitution))
}