import Foundation
let pattern = #"\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[MEDIA=sketchfab]$1[/MEDIA]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)