const regex = /\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[sketchfab\\]https:\\\/\\\/sketchfab.com\\\/models\\\/([^\\[]+)\\[\\\/sketchfab\\]', 'g')
const str = `[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]`;
const subst = `[MEDIA=sketchfab]$1[/MEDIA]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);