import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[sketchfab\\]https:\\/\\/sketchfab.com\\/models\\/([^\\[]+)\\[\\/sketchfab\\]";
final String string = "[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]";
final String subst = "[MEDIA=sketchfab]$1[/MEDIA]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}