re = /\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]/
str = '[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]'
subst = '[MEDIA=sketchfab]$1[/MEDIA]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result