// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]").unwrap();
let string = "[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]";
let substitution = "[MEDIA=sketchfab]$1[/MEDIA]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}