import re
regex = re.compile(r"\[sketchfab\]https:\/\/sketchfab.com\/models\/([^\[]+)\[\/sketchfab\]")
test_str = "[sketchfab]https://sketchfab.com/models/ce1b37915f40429ab5567cba35ec549f[/sketchfab]"
subst = "[MEDIA=sketchfab]$1[/MEDIA]"
result = regex.sub(subst, test_str)
if result:
print(result)