# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/eot\?[^'"]+/eot/g;t' <<< "@font-face {
src: url('../some-font.eot?v=4.6.3');
}"