const regex = /eot\?[^'"]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('eot\\?[^\'"]+', 'g')
const str = `@font-face {
src: url('../some-font.eot?v=4.6.3');
}`;
const subst = `eot`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);