package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`eot\?[^'"]+`)
var str = `@font-face {
src: url('../some-font.eot?v=4.6.3');
}`
var substitution = "eot"
fmt.Println(re.ReplaceAllString(str, substitution))
}