$re = '/eot\?[^\'"]+/';
$str = '@font-face {
src: url(\'../some-font.eot?v=4.6.3\');
}';
$subst = "eot";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;