import re
regex = re.compile(r"eot\?[^'\"]+")
test_str = ("@font-face { \n"
" src: url('../some-font.eot?v=4.6.3');\n"
"}")
subst = "eot"
result = regex.sub(subst, test_str)
if result:
print(result)