re = /eot\?[^'"]+/
str = '@font-face {
src: url(\'../some-font.eot?v=4.6.3\');
}'
subst = 'eot'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result