import Foundation
let pattern = #"eot\?[^'"]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@font-face {
src: url('../some-font.eot?v=4.6.3');
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"eot"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)