// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"eot\?[^'"]+"#).unwrap();
let string = "@font-face {
src: url('../some-font.eot?v=4.6.3');
}";
let substitution = "eot";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}