use strict;
my $str = '@font-face {
src: url(\'../some-font.eot?v=4.6.3\');
}';
my $regex = qr/eot\?[^'"]+/p;
my $subst = 'eot';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";