# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)/\1(\2.html)/g;t' <<< "Some [word](link1) which [looks](link2) like this"