package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)`)
var str = `Some [word](link1) which [looks](link2) like this`
var substitution = "\1(\2.html)"
fmt.Println(re.ReplaceAllString(str, substitution))
}