using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)";
string substitution = @"\1(\2.html)";
string input = @"Some [word](link1) which [looks](link2) like this";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}