import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^!()[]]*)(\\[[^]]+\\])\\(([^.)]+)(\\.md)?\\)";
final String string = "Some [word](link1) which [looks](link2) like this";
final String subst = "\\1(\\2.html)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}