import Foundation
let pattern = #"([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Some [word](link1) which [looks](link2) like this"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1(\2.html)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)