// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)").unwrap();
let string = "Some [word](link1) which [looks](link2) like this";
let substitution = "\\1(\\2.html)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}