re = /([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)/
str = 'Some [word](link1) which [looks](link2) like this'
subst = '\\1(\\2.html)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result