#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)"
Local $sString = "Some [word](link1) which [looks](link2) like this"
Local $sSubst = "\1(\2.html)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)