import re
regex = re.compile(r"([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)")
test_str = "Some [word](link1) which [looks](link2) like this"
subst = "\\1(\\2.html)"
result = regex.sub(subst, test_str)
if result:
print(result)