using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b|\d+)([a-z])|[\d+ +!.@]";
string substitution = @"\U\1";
string input = @"Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}